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This tutorial illustrates HCS analyzer functionalities, showing how the user can handle the analysis of an entire High Content Screening exported database.
For this tutorial, we used an artificially generated siRNA screening database composed of 25473 wells distributed over 68 plates. The plate format is a regular 384 wells plate, with 24 columns and 16 rows.
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[bookmark: _Ref318273566]Import Screening

Even if HCS analyzer is able to import MTR files, it has been principally designed to load CSV file. In such file 2 columns are mandatory: one column containing the plate name and another one with the well absolute position of the well. Each row represents a well where any descriptors can be added in a double format. The user has the possibility to add 3 others specific data:
	- A name (compounds or siRNA name by example) as a string
	- An information as a string
	- A Locus ID as an integer that will allow the software to make the link to KEGG database.
Here is a typical example of such file generated by MS Excel and save in CSV format. 
Note: The names as well as the position of the column do not have to follow any rule as the software loader is flexible enough to deal with this kind of variability.


[image: ]
Note: HCS analyzer can deal with two different well positioning modes that can be selected in the options window.
1- [image: ]Single Mode: The row position is given by an alphabetical character. Row and column positions are merged together in a single column.
2-  Double Mode: One column has to be created for the row position and one for the column. 


Regarding the selected mode, the loading window options will be adapted.


First, click on “Import Screen” from the “File” Menu, and locate the file to be loaded.  
[image: ]
[image: ]
The Import window should popup such as below. The software reads 4 rows to help the user to define its choice.
Define the plate dimensions, select all the requested descriptors as well as the other useful information such as Locus ID, Info or Name (if needed) click “Ok”. A message box should appear giving you the information about the number of loaded well.
Note: In order to avoid any trouble during the process, the software does not accept any undefined well. It means that if any readout is missing, the concerned well will be automatically rejected.
[bookmark: _Ref318273569]Define Controls (if present)

Positive and/or negative controls have been performed during the screening process; the user can define them manually. First choose the desired class using the dedicated control, then using the mouse select the corresponding wells.
Note[image: ]: It is easier to see the selection by switching to the “Display Class Mode”.
Note: By default “Apply to all plates” is checked. Thus the current selection will be performed on every active plate.
[bookmark: _Ref318273570]Quality control

Many different way control the quality have been implemented in HCS analyzer. The Z-factor is a commonly used one that the user can test either on the current plate by clicking on “Plate->Quality Controls->Z-Factor” or “Screen->Quality Controls->Z-Factor”.
[image: ]

[image: ]
In the first case, the Z-factor is computed on the current plate for each active descriptor and the results are sorted from the highest to the lowest. If performed on the complete screen, only the active descriptor is taken into account, and the associated Z-factor is represented for all the active plates allowing a rapid estimation of the low quality plates. Based on that, the user can reject the plate with a Z-Factor higher than a certain threshold by clicking on the “Reject Pates” button.
[image: ]
The active plate list has then been modified, and a new Z-factor visualization gives: 
[image: ]
The user can always display and modified the plate list by clicking on “View -> Plates Manager”. The left column represent the complete set of loaded plates and the right column the set of active plates that will be processed.

[image: ]
[image: ]In certain situation, assessing the normality of a descritpor readout on a control set of wells can also provide a precious information about the data quality. To check this, the user will select a descriptor, a class and then click either on “Plate -> Visualization -> Histogram” 

[image: ]Note: The histogram display and computation is highly modifiable through the  “Edit->Options” window.
or “Plate -> Quality Controls -> Normal Probability Plots”.
Note: Those displays can also be generated for complete screen by going to “Screen” menu.
[image: ]If the user is interested by assessing the quality of a particular set of well among the complete screen, he can click on “Screen->Quality Controls->Descriptor Evolution” and check the evolution of the average values and standard deviations of the selected class.




[bookmark: _Ref318273571]Descriptor Selection

The presented application is clearly targeting screening multivariate data. In such context one important step in the data analysis is identify redundant source of information. Typically the identification of two correlated descriptors has to be identified either to perform better in the classification or clustering step, but can also be of great interest in understanding some biological mechanism of action.
[image: ]If the user is interested by the quality of the descriptors in term of information, he can click on “Plate->Quality Controls->Correlation Matrix” (or its equivalent “Screen->Quality Controls->Correlation Matrix” to display the correlation matrix of the active descriptors). The process will display first the correlation matrix (by default the absolute value of the Pearson coefficient),

Note: For this process all the activated wells are taken into account (no specific class).
[image: ]then the ranking of the coefficient to easily identify correlated coefficients.

Note: The user can select the Spearman coefficient and remove the ranking display by changing the options in the “Edit->Options” menu.
HCS Analyzer provides different approaches for automated feature selection. Those methodologies are available by clicking on the “Dimensionality Reduction” tab.
[image: ]
At this stage, one can choose between two different kinds of approaches: Unsupervised or Supervised. Compare to Supervised, Unsupervised dimensionality reduction methods do not required any predefined classes.
Unsupervised: In this version of the software, two unsupervised methods are available: PCA or Greedy Stepwise. 
[image: ]
Note: whatever the feature selection algorithm is selected, a warning message box will appear prior to the process, reminding the user that the active descriptor list will be modified. 
[image: ]
If the PCA algorithm is selected, all the active wells will be used to identified the most important descriptors (i.e. the features maximizing the deviance of the data), reducing the dimension to the selected value.
[image: ]
Unlike the PCA, the greedy stepwise does not reduce the number of feature to a user selected value. The final number of features is automatically chosen by the software.
Supervised: As said above, supervised methods require a pre-defined set of classes. Let’s select two controls as class 0 and 1 and keep the rest of the plate as class 2.
[image: ]
The algorithms will then choose the features that separate the more efficiently the classes, but will not take into account the well corresponding to the neutral class. In such way, the user can focus on identifying  important features required for maximizing the difference between controls only.
[image: ]
At this stage, the user has access to 3 different methods: InfoGain, OneR and Greedy.
[image: ]
InfoGain will operate regularly by reducing the dimensions to the user selected value. OneR operates the same way; however, in this case, the user has a feedback from the algorithm through the text box, giving him the opportunity to check the weights associated to every descriptor.
[bookmark: _Ref318273573]Phenotypic clustering

For the purpose of this section, let’s start buy generating an univariate artificial screening by clicking on file->Generate Screen->Univariate
[image: ]

Change the standard deviation of the compound distribution to 0 and push the standard deviation popup button as it is shown on the picture below.
[image: ]

This means that the compound distribution (Gaussian) will have a variable standard deviation starting 0 and increasing by 30 (defined on the option window as show below) on every plate (here 10 plates are defined).
[image: ]
Click Ok to generate the 10 plates. Starting from:
[image: ]
To 
[image: ]
The evolution of the screening data quality can be monitor by clicking on Screen->Visualization->Scatter Points

[image: ]
More precisely, using Screen->Quality Controls->Descriptor Evolution and by selecting the class 2 (here the compounds), we obtain: 
[image: ]
Note: As only the compounds distribution has been subjected to a variation over the plate index, a quality control such as the Z-factor should not vary over the screening. This can be assess by clicking on Screen->Quality Controls->Z-score

[image: ]
The stacked histogram (available by clicking on Screen->Visualization->Stacked Histogram) provide also a convenient way of displaying the data distribution:
[image: ]
Let’s jump directly to the clustering step by clicking on the Classification & Clustering tab.
[image: ]

First select the clustering algorithm:
[image: ]

When using K-Means, the user has to select the number of expected class. Let’s choose 3 (2 controls + 1 compound distributions). 
[image: ]
First, we will start by checking the Plate By Plate radio button. In this case, the clustering will be operated on each plate independently. 
Note: In such case, no consistency is guarantee for the class association from one plate to another.
Click on Cluster to process the entire screening. Let’s come back to the plate visualization tab, and press the popup button Display Class to monitor the result.
[image: ]
As said above, the class association is random (here the compound and the controls have been inverted). However, in term of clustering, the process was successful by differentiating the controls and compounds properly.
As the noise is increasing the clustering becomes fuzzy as show on the next figure:
[image: ]
In such case, the Screen->Visualization->Scatter Points give us a good overview of the phenomena.
[image: ]
Let’s apply the same clustering method but this time performed in one time over the entire screen.
[image: ]

The resulting scatter points graph gives:
[image: ]
As usual the class association is still random, but now as the screening is process globally, there is a consistence from one plate to another.
By choosing another clustering approach such as the Expectation–maximization algorithm (EM), it is possible to automatically identify the optimal number of cluster. Let’s perform it his way
[image: ]
Note: This operation can be time consuming.
The number of identified clusters can be check on the dedicated console.
[image: ]
It is interesting to see that on plate_6, four clusters have been detected.
[image: ]
In this case, the controls have distinguished as well as two phenotypes within the compounds class.
[image: ]
If the same operation is performed in the entire screening in once, 7 clusters are obtained.
Note: if the cluster number identified by the EM is higher than 10, then the process is cancelled.
[image: ]
For such an approach, the stacked histogram is the most relevant way for understanding the clustering.
[image: ]

The controls have been properly identified; however, the compound distribution has been split in five distinct Gaussian distributions.
 Now we can convert the entire screen wells into class2 (click on Global).
[image: ]
Then un-select the two controls, in order to remove them from further analysis.
[image: ]
The plate design should look like this:
[image: ]
The idea now is to perform a standardization of the data. For that, click on the Normalization tab, select Standardization and apply it to the class2 previously defined.
[image: ]
This operation is one of the few process that will modify the data.
[image: ]
Due to the data structure, the first plate has not been processed (null standard deviation).
[image: ]
The full screening scatter points are then difficult to read.
[image: ]
This can be fixed by removing the plate0 from the list of active plate (View-> Plates Manager).
[image: ]
The scatter points become then:
[image: ]
Finally, we can apply an EM clustering with an automated number of cluster identification.
[image: ]
As expected, only one cluster has been identified, as it is display on the histogram visualization.

[image: ]

HCS analyzer provides also a dendogram visualization of the data. The visualization is common in biology and provides a convenient way to check the signature distributions over a limited number of experiments. Let’s start by generating a multivariate screening composed of a single plate with a  10 dimensions signature as follow:
[image: ]
Go to the menu Plate->Visualization->Hierarchical Tree 

[image: ]
 a window as follow should appear

[image: ]
On the very left side of the dendogram, the user can see the color related to the well classes, followed by the well position. Then, next comes the signature associated to the well.
Note: each descriptor is separately normalized between -1 to +1.
And finally the tree by itself. One can access the tree options by displaying the option window and selecting the Clustering->Hierarchical box.
[image: ]
Note: those options will be also applied for the hierarchical clustering process
[image: ]
The user has to remember that such hierarchical clustering computation is highly related to the number of wells involved. Thus, the computational time can increase a lot for high number of data points, and the related dendogram display becomes quickly unclear.
[bookmark: _Ref318273574]Phenotypic classification

For a clear understanding of the phenotypic classification, we will start this section by generating an artificial multivariate screening.
Click on file->Generate Screen->Multivariate.
[image: ]
Increase the dimension of the data to 4, and keep the original set-up for the other parameters.

[image: ]
In such a mode 10 plates containing 3 different phenotypes (represented by multivariate Gaussian distribution, in a 4 dimension space, with means and standard deviations defined in the control). Phenotype 0 and 1 will be located respectively at column 0 and 1. 
Click Generate.
[image: ]
[bookmark: _GoBack]You can look at the points distributions along the different axis by clicking on Screen (or Plate) -> Visualization -> XY scatter points, and by choosing different descriptors along the axis.
[image: ]

In such example, the phenotypes are clearly defined and well separated. We can also visualize the linear discriminant analysis (LDA) on a plate. To do that, click on Plate->Visualization->LDA
[image: ]
The user has to select a class that will not be taken into account for LDA computation but by projected in the resulting space. Let’s choose Phenotype 2 (in dark green).
[image: ]
The horizontal axis of this space represents the linear component that maximize here the separation between the phenotypes 0 and 1 (light green and red).
If we consider those phenotypes as controls, we can then perform a supervised classification by displaying the corresponding tab.
[image: ]
The classification algorithm can be selected here.

[image: ]

if the Plate By Plate radio button is checked, then each plate will be considered independently. It means that, the learning step will be performed on each plate and the classification will follow. If the Full Screen radio button is checked then, the learning step will be performed on all the screening data, then applied to all the wells. 
Note: In a full screen process, the user will have to perform normalization step to make the data consistent.
The user has to specified a To Be Classified  class. This class will not be taken into account for the learning step, but will be (as all the other wells) classified. Typically, this represent the screened compounds.
[image: ]
Let’s choose Class 2, and then press Classify button.
[image: ]
When done, information about the classification process is displayed, and in the case of C4.5 classification, the user has the opportunity to access each resulting tree. The trees are associated to each plate, and then the user has to selected the plate first and after either using the shortkey Ctrl+T or click on Plate->Visualization->Classification Tree.

[image: ]
By going back to the plate visualization, the user can assess the quality of the results.
[image: ]
In this specific case, the classification is obvious, and the compounds have been classified in the same category as the phenotype 1.
[image: ]


[bookmark: _Ref318273576]siRNA screening 

In the context of siRNA screening, and if the user has locus ID associated to each well, we offer the possibility to connect the application to gather information about the genes involved as well as the pathways.
While loadint the screening the user has to specify the Locus ID such as follow:
[image: ]
In such context, the locus ID will be associated to each well. By right clicking and selecting Info from the contextual menu, the user can check the locus ID of a specific well.
[image: ]
The user can also select Kegg to initiate a connection to the Kegg server.

[image: ]
Note: for the option an internet connection is required.
If information about the gene are available, a window such as follow will be displayed.
[image: ]
Where the gene of interest is highlighted in orange. In parallel, another window displays the pathway(s) related to this gene.
[image: ]
By double clicking on the pathway of interest, another window pops up, providing information about it.
[image: ]
In order to extract automatically information about the pathways involved in a certain phenotype, the user can select the following menu Screen->Gene Analysis->Pathways analysis.
[image: ]

The application will then parse all the genes/well of the current selected class and gather the pathways related. At the end of the process, a pie chart displays the ratio of pathways involved and extracts the most recurrent.
[image: ]
Notes: Due to the internet connections, this process is highly time consuming. This operation can be performed during the report process.


[bookmark: _Ref318273443]Development

Start by extracting the complete solution from the “HCSAnalyzer.zip” file.
[image: ]
Double click on the solution file to launch the development environment tool.
[image: ]
One solution (“HCS Analyzer”) containing two projects (“HCS Analyzer” and “HCSPlugin”) has to be loaded.
[image: ] 
Press debug to launch the software.
[image: ]


[bookmark: _Ref318273578]Plugin Development

Open the HCSAnalyzer solution as describe above. Add a new project to the solution.
[image: ]
Choose the “HCSAnalyzer Plugin” template and specify the name:
[image: ]
Note:  To have access to this template, the “HCSAnalyzer Plugin.zip” has to be present in your Visual Studio template directory (e.g.:
 “C:\Users\Myself\Documents\Visual Studio 2010\Templates\ProjectTemplates”).
At this stage you need to add two references to your plugin project :
[image: ]
Click on the “Browse” tab, and go to your HCSAnalyzer development directory (probably something like “C:\HCSAnalyzer\bin\Debug”) and select “HCSAnalyzer.exe” and “HCSPlugin.dll”
[image: ]
Once compiled, your plugin needs to be located in your HCSAnalyzer plugins directory. To do that automatically, double click on plugin Properties, and go the “Build Events” tab:
[image: ]
and specify your plugins directory in the “Post-build event command line:” (here “copy "$(TargetPath)"  "E:\HCSAnalyzer\bin\Debug\Plugins" ”)
[image: ]
Finally give a name and a menu location to your plugin by clicking on the “Resources” tab and by filling out the three corresponding cells:
[image: ]
You can then develop your plugin and launch the HCSAnalyzer application. Your plugin will be available through the menu “Plug-ins”
[image: ]
4

image2.png
Coslation s | Misc.

import/ Expot | Dispay | Nomalzation

Wel postion mode:
01

© Snge Mode.

Import Names.





image92.png
s oo W N

Eile Edit View Project Build Debug Team Data Tools Architecture Test Analyze Window Help
S @4 DLB[9 - S5 b Dby (@M |5 e BlE -

4+ General Bl
123 Solution HCS Analyzer’ G projects)
Therere no usable Configuration: N/A Platform: [N/A " 0 HCS Analyzer
Dragon em oo s > (@ HeSPlugin
testto add tto the Pre-build event command fine: 4 (3 My HCS Analyzer Plugin
toolbox, + 2. Propeties
] Assemblylnfo.cs
b G Resourcesiesx
b [ Settingssettings
4 [ References
-3 HCSAnalyzer
-3 HCSPlugin
-3 System
-3 System Core
-3 System Drawing
-3 System Windows.Forms
» [ Fomics

0 Solution Bxlorer

=t





image93.png
©9 HCS Analyzer - Microsoft Visual Studio (Administrator)

Eile Edit View Project Build Debug Team Data Tools Architecture Test Analyze Window Help
S d |4 LB[9- -5 b b (@ - T R BB .

4 General

Strings + ] Add Resource ~ X Remove Resource | - - | Access Modifier: 23 Solution "HCS Analyzer' 3 projects)
o vt B0 e
Drag an item onto this Vatoe p— b (3 HCSPlugin
textto add it to the 4 (3 My HCS Analyzer Plugin
toolbor: Myself -
Data Analysis ] Assemblylnfo.cs
b 5 Resources.resc
b E) Settings.settings
4 [ References
3 HCSAnslyzer
3 HCSPlugin
3 System
3 System.Core
3 System.Draving
3 System.Mindows Forms
» [ Fomics

0 Solution Bxlorer

same Sting
ELE
(Name)

Comment

Filename
Persistence

(Name)
Name used to identify the resource in code.





image94.png
©0 HCS Analyzer (Running) - Microsoft Visual Studio (Administrator) =

Fie Edt View Project Buld Debug Team Data Tools Architecture Test Anshze Window Felp
Sidd & ™M | R G B8 -
- Solution Biplorer - x
]
- SolutionHCS Anslyzer @ projects 3
3 HCS Analyzer
@ HCSPlugin

2 3 My HCS Analyzer Plugin

4 [ Properties

e e merio . L =

File  Edit ~ Plate Screen  View | Plug-ins | Help

R 1y HCS Anaiyzer Plugin

4 General

Resources Gl Strings ~ ] Add Resource ~

There are no usable controls i this group. Drag
an item onto this text to add it to the toolbox.

| Datadnalysis » | ComputeEcs0- myse |} Class selction
Systemtic Eror dertfication & Conection || |\~ "] Nomalizaion || [~ | Usefcaton S CUSIemg || Y22 | Repor Expot Postive 0) T

Curent Plate || /=] Dimensionalty Reduction

(sl

Giobalorly
Selected

7] Applyto ol pltes:





image3.png




image4.png
Pite Dimensons

Comns 4

Fows  [i6 B
Dt Name Feadout 0 Feadout 1 Feadout 2 Feadout 3
Piate3e SRPODDMSS  [SRPODDSTS  |SRPODOS0Z | SRPODO469
Vel 384w 024 3 Gt B3

s e Duggabie Duggabie Duggabe Duggabe
|Catalog Number 1 2 3 4
|Gene Symbol 1 2
Description | adrenocortical dy... | deleted in esoph... | hypothetical prot... | hypothetical prot...
Locus 1D 65057 115128 57574 B
Fuot os2285%¢ 0723304 05050863 0756245
ES osezez 0567035 07260621 0432258
Voume sozeotised  |1e37iie  |1370028% |sessreze?
Fatol Teszsie  |2a0wesie |11 1964220228
Fuo2 00408855 | 1765919403 |7461606763 |54.35359857
Tedure weszuz s |tssosuse  |11e3ssT
Fandt los77es |osossd0s7  |s4ea0sedt | 3554z97s6e
Fandz fosois mssenion sasiasie|an7isean
Fand? ToaoTe 202276l |A0450128  |46304418%0
Fandé Temeisy  |2aew7se  [03o7esan (989100083

(——]





image5.png
The selection has

Manually selected been applied on
controls each plate Select the class
A A A

Display class mode




image6.png
-t

0047

0095

0202

0295

0393

Texure

Size

Flo2

Volume.





image7.png
4
i
:

95000
05000
L6000
86000
96000
e6000S
VBr000S
6000
09y000s
o000
8s000S
6rY000S
S2y000S
83000
1rvo0ods
Zar000ds
82000
Ssp000S
Zoroonds
Erro00s
9zy000S
Lavo00ds
o000
voroondus
Sa000S
Lov0onds
1 Lvooods
ecvo00ds
2Zevoonds
0zyo0s
oBr000S
89000
06000
18vo000dus
63000
Levoonds
Zaroonds
8vY000S
Vo000
Varoo0ds
Lvroonds
rroo0ds
ovyo00s
e0s000S
Spy000S
16v000dHs
15vo00ds
ovyoonds
1050004
Zvroonds
Zaroonds
L5000
05y000S
66000
£sy000S
ear000s
8er000S
varoonds
Sop000s
6Er000S
99r000S
oBr000S
vevoonds
eor0ns
69r000S
Zosoonds
6000
63000





image8.png
HCS analyzer v10.

File Edit SRPO0OISO -+ Plate Screen View Plugdins  Help

Clss ssection
Curert Pite |[)—=L_| Dinensionsity Reduction | | 1. | Systematic eroridertfication & conecton [ |\~ | Nomaizaton Gassiicatio & Clusering Fostne © 1%
Corecton Relecion Curent Descrptor
oo - B Fuot -
Threshold  0.50 $
[E5oor. [Z-Scor based jecton
|For more information. go to: |Remove plates with a lower Zfactor values than
|defined by the thresold.

[For more irformation. go to:

FE— | [





image9.png
Z-factors.
Export  Copy to Clipboard

Texture Z-factors.

asvo00us
S050004S
L6v000HS
8640005
aBv000HS

e6000S

0918

ovonnans
oo
oo
cosonas
o
oo
e
o
o
o
s
o
o
o
st
v
o
sovonnans
o
e
Lusonags
ctvomans
o
covonnans
oo
oo
v
o
vonans
oo
sosonnans
o
oo
oo
cosnnas
s
Lesonags
Issonags
Losongs
oo
o
o
osonnas
oo
o
£ o
g o
vonnans
oo
o
oo
oo
oo
oo
oo
stvomans
oo





image10.png




image11.png
& Class 8 - SRPO00450 - Texture histogram.

[ S

Export  Copy to Clipboard.

Class 8 - SRP000459 - Texture histogram.

1

12

11353

10

Sum

ul

76.49

176.49

Texture

276.49

37649





image12.png




image13.png
& SimpleForm

Export  Copy to Clipboard

Class 7 Fluo1 evolution

08
06
04
02

1oy

v
prommnd
Lovonnas
anvonnais
aovonais
Crbonns
Vs
Spunnis
oovonais
oosons
v
vt
Sevunns
ot
e
Jittme
auponnais
etmmnd
v
oS
auponnais
e
cavonnais
e
Spunns
ity
Jvnnns
civonnas
v
Huponnais
Sevonnas
e
oovonas
rémmnd
e
e
cavonnais
s
e
e
ivvonnais
s
s
it
Srvunns
Tvnnnis
Isynnns
vt
e
o
v
e
v
it
v
Cabonns
soponnas
ey
Sounnis
e
oovonas
e
vivonns
Jirtmey
b
e
Beponnais
et





image14.png




image15.png
0080080012007 00200260280 03100320 0330 TBED 4

ot Rt | Rt Voura | a2

Al Ak velee et Al
Rardl Rt Rt Rani2 a2 Fani2

Tewe el Sk Velme Sk Al





image16.png
16 HCS analyzer v1.03 =

Cissselecion
Chssfcaon & Cserng PoireO) P
Coret Descgtor
New Dimenson 2 z CorertDessptor
Fuot -
© Unsupervied © Supenised
e - focan
el
[Principal Component Analysis. [InfoGain.
Formre omaton. g0 10 For mor efomaten, oo
e R p— e A
fosie et rees





image17.png




image18.png
Warning

A By applying this process, selected descriptors lst will be modified |
Procesd 7





image19.png
Size

Ratio1
Fluo2
Texture
Rand1
Rand2
Rand3
Rand4




image20.png
1 HCS analyzerv1.03

Plate Screen View Plug-ins  Help





image21.png




image22.png
© Supervised





image23.png
1 HCS analyzer v1.0.3

File | Edit
@& LoadScreen  Ctrl+L

§4 ImportScreen Ctrl+] Dimensionalty Reduction HI] Sy
[ Generate Screen v Univariate Ctrl+G

» Multivariate  Ctrl+Alt+G

Link Data

Exit Ctrl+X




image24.png
[ Bias | Value disrbutions

1

18000

[100.0





image25.png
Import / Export | Display | Clustering | Classfication | Comsation matrx |

Misc. | Enors ldentf. & Corect. |

‘Compound noise Std Dev.

Row efect shit

Ratio XY

(a0 =





image26.png
£ HCS analyzer v103

[EENEEE

File  Edit [EEED

-] Plate  Screen

)—m_| Dimensionaty Reduction

Toz=zZrAS-TOTNMOO® >

Systematc Eror dentiication & Corection

View Plug-ins  Help
|o= | Nomalzation

Classfication & Clstering

Report Export

Giobal

Giobalorly
Selected

7] Aol to ol pstes

Display lass

1903844

2137

Postive (0)

Curent Desorptor

Descrptor_0

Descrptor List

7] Desciptor_0





image27.png
Class selection
Postive (0)

Curent Desorptor

Descrptor_0
Descrptor List

2 | Repot Egott

Classfication & Clstering

Help

Plugrins

Nomalzation

View

Screen

Plate

Systematic Eror entfication & Corection

Edit

Curent Plste [ /=] Dimensionalty Reduction

File

162 HCS analyzer v1.03

1948.906

11697

Display cass

Applyto al plates

ANESHRNNNNNNNEEN
-0000B00000080000





image28.png
 Scatter Point / 3840 points o i
Export Copy to Clipboard

2500

2000

1000

indexc

2000

3000





image29.png
& SimpleForm

Export  Copy to Clipboard

1400

1200

1000

Descriptor 0

Class 2 Descriptor_0 evolution

Plate_0

Plate_1

Plate_2

Plate_3 Plate_4 Plate_5 Plate_6 Plate_7 Plate_8 Plate_9





image30.png
& Z-factors

Export  Copy to Clipboard

15

0655

Descriptor_0 Z-factors

0715





image31.png
™ Pm,nrns_

Export  Copy to Clipboard.

Plate_0 - Descriptor_0 Stacked histogram.

1200

1000

g

-162.51 33749 83749 133749 1.837.49
Descriptor_0





image32.png
164 HCS analyzer v1.03

File Edit Plate 0

A

Clsteing

KMeans -

© PoteByPate  © Ful Soreen

Cluster Number 2 4 [ Auomated

a5 -

© PateByPaste () Full Soreen

To Be Classfied 2

[KMeans.
[For more irformation. go to:
|to://on wiipedia.ora/iwki/Kmeans dustering

[c45.
[For more irformation. go to:
lto://en wiinedia ora/wiki/C4 5 dlaorthm

Gasﬁmml()ﬂ.ung‘





image33.png




image34.png
Clustering

KMeans -

Piaiz By Pisic

fnconsistent from one plate to another.




image35.png
£ HCS analyzerv1.03 [E=REEET

Fle Edt Plated - Plte Screen View Plugins Help
)—=+l_| Dinensionalty Reduction || 1, | Systematic Eror dentfcation & Corecton || [\~ | Nomalzaion || [i(* | Giassfication & Clustering Report Export Postive () < I
190844 | Curent Desciptor
e Descrptor 0 -
Descrptor st
Getalory 7] Descptor 0

7] Aoplyto al pates

2137

Toz=zZrAS-TOTNMOO® >





image36.png
4 HCS analyzer v1.03 (= [ ]

File  Edit ] -] Plate Screen View Plugrins  Help

aopnc Pyrs— oy [res——

Plate 2

y 1948506





image37.png
Export  Copy to Clipboard

2500

v 0





image38.png
Clustering.

KMeans -

Plate By Plate

Cluster Number [3 : Automated





image39.png
D
d

‘Copyto Cipbord

2500





image40.png
Clustering

Piaiz By Pisic

Automated

fnconsistent from one plate to another.




image41.png




image42.png
Plate 6





image43.png
£ HCS analyzerv1.03 [E=SNEERTE
File  Edit [T | Plate Screen View Plug-ins  Help
=] Dimensonsity Reducton Syt Eror dnticaton & Corstion || 1A= | Nomalaaton Gassfcaton 8 Custeng Repor ot S

Toz=zZrAS-TOTNMOO® >

Giobalorly
Selected

9] Apolyto ll pltes:

1971142

Curent Desorptor

Descrptor_0

Descrptor List

[9] Descrptor_0





image44.png
SOPET TITR)]
oY et e P ) A

Descriptor_0





image45.png
SRR =

Export  Copy to Clipboard.

Plate_6 - Descriptor_0 Stacked histogram.

1200

1000

g

-162.51 33749 83749 133749 1.837.49
Descriptor_0





image46.png




image47.png




image48.png
162 HCS analyzer v1

View

Plugrins

Help

Aopiyto all p

1971.182

Descrptor_0





image49.png
4 HCS analyzer v1.03 5
File Edt [Plte6

s selection
Unselected ()~ 0

Clssfication & Custering

[For more information. &
|to://en wiipedia ora/wiki/Standard score





image50.png
Warning

A\, By sopting tisprocess, data will e defiiively moied ! Proceed





image51.png
[Standardzation
[Data are shiedito the average valve of the
Inegative class, then dvided by the standard
|deviation o the negative dass data distrbution
[For more nformation. go to

lto//on wiinedia ora/wiki/Standard score
[Plate_0 - Descrptor_0, Sandard deviaton =
fprocess cancelled





image52.png
Export

Copyto Clipboard.

1200





image53.png
e HCS analyzer vL03

[=/@] =

Fe g [P0

[ e e View Plagie Hap

Cisss selecton
Curent Plate [ /=l Dimensionalty Reduction Systematic Eror dertfcston & Corecton | [ [~ | Nomaization e s (1)
Curert Descrptor
Descrptor 0
Descrptor it
Plates manag o0
Avsible Pltes To Be Processed
Plte 0 :
pate1 Pite_1
Plte2 pdd> Pate2
Pae3 Pae3
paed Paed
Paes Paes
Paes <Remove ]
pae7 Pae 7
Pae® Paet
Paes Paes





image54.png
Export

tter Point / 3168 points

Copy to Clipboard

(| B |

4

criplor 0

500

2500 3000
indexc





image55.png




image56.png
Positive (0) - Descriptor O i =]

Export  Copy to Clipboard

Positive (0) - Descriptor_0 histogram.

3844

150.

Sum

100

Descriptor_0





image57.png
L]

10

Plate

Numberof Piates





image58.png
£ HCS analyzer v103 ==

Fie Et Pite <[ Plte | scren View Plugins _Hep
scrarpams cr | Coss lcton

Currt Pt |[ 1o+ Dimensonalty Reducton | [ 1, | Systemtic Ero e

Quality Controls  » Histogram CtreH EE Postive (0} -

0 1 12 14 &Y &0 160805 Curent Desciptor

1 2 6
(1 I N N N N . LA cuo ‘7 Descrpor 0 -

Clssfication Tree T G|

XY Scatter Points  Ctrl+Y Descrptor List

fobal orly ‘

T ——— T e

Descrptor_0
Descrptor_1
Descrptor 2
Descrptor_3
Descrptor_¢
Descrptor_5
Descrptor_6
Descrptor_7
Descrptor_8
Descrptor_9

7] Applyto ol pltes:

YNNI SNEE





image59.png
16 Dendogram. Euciidean distance. Link type: SINGLE.

Options

|1





image60.png
Misc. | Erors identf. & Conect|

import/ Expot | Dispay | Cisietng || Cassfication | Corsition matrx
Herarchical

Disance Eucidean -

Lk Type. SINGLE -





image61.png
1 Dendogram. Euciidean distance. Link type: WARD

Jaxal

i
sl

)
7





image62.png
£ HCS analyzer v103

File | Edit

& loadSaeen  Cull |
G4 ImportScreen Cttel |Dimensionalty Reducion | [ .| Sy

Generate Screen Univariate Ctil-6
Multivariate Ctrl-Alt-G.





image63.png




image64.png
£ HCS analyzer v103 =[5 f

File  Edit

[ Pote Saen View Plugins Help

Class selction
fcaion s Carecion| | [ | Nornalasion r— Repor ot ot o]

718 19 20 21 2 23 5631 Curent Descrptor
Descrptor_0 -

Gobal i

Descrptor it

Gobal orly Descrptor,

= s

Descrptor 2
Descrptor_3

Aoplyto al plates

0
AERERERNNENR
CDENCENRRECOEE
DENENECRRDEN
NOERCENCOCED





image65.png
Scatter Point / 3840 poir

Export  Copy to Clipboard.

Descrptor_0 -

Descriptor 0

116.378720899276

90.7049388502277

65.0312568011797

39.3575247521317

13.6837927030837

-11.9899393459643

13.9803431322331 30.1857272102999 64.3911112683657 89.5964953654335 1148018794445
Descriptor_1





image66.png
£ HCS analyzer v103 :

File Edit Plated -+ Plate Screen View Plugins  Help

Systematic Eror dertfcston & Corecton | [ [~ | Nomaization

Ossfication & Custering | | 123 | Report Expot

115631
BN
Gobalonty
Seeced
= Aoy to ol pates
Posiive|
M Negative
2
Diplay clse
2215

)
0





image67.png
Export  Copy to Clipboard

12,68

v 240858

0372Descripto

7.0+ 0.328Descriptor_

0153 Descripto

4346 9345 14346
0.333Descriptor_0-+0.507xDescriptor_1 +0.348xDescriptor_2 +0.714xDescriptor_3





image68.png
16 HCS analyzer v1.03

File Edit Plate 0

A

Clusteing Clssfication
KMeans - a5 -
© PoteByPate  © Ful Soreen © PateByPaste () Full Soreen
Cluster Number 2 4 [ Auomated To Be Classfied 2
[KMeans. [c45.
[For more irformation. go to: [For more nformation, go o:
|to://on wiipedia.ora/iwki/Kmeans dustering lto://en wiinedia ora/wiki/C4 5 dlaorthm

Gasﬁmml()ﬂ.ung‘

i

Desciptor_2

E





image69.png




image70.png




image71.png
1 HS analyzer v1.03 [e[al = ]

Fle Edit Plated - Phte Screen View Plugins Help
Classselction
1| Systematic Erorldentfication & Correction | | | Nomaization Ossfication & Clustering Fostne @) -
Classfication Curent Descriptor
s B Descrptor 0 -
Descrpor Lt
Plate By Plate. Plate By Plate. Descrptor 0
Descrptor_1
Cluster Number |2 = Automated To Be Classfied 2 A Descriptor. 2
Descrpior 3
[Kiears. 625,
[For more irformation. go to [For more nformation, go to: Pr—— [ =
It/ Jen wikipedis ora/ki/Kimeans clsteing it/ Jen wikipedis ora/uki/C4 slgortm —
1145 -2 classes - Pate: Plate_DOK
1148 2 classes - Piat: Plate_1 OK
1148 2 clsses - Pite: ite_20K C4.5 classifcation process finished
1148 -2 classes - ate: late_3 0K Press (Ctl=T) for current pate ree.
1148 2 classes - Piate: Plate_4 OK
1148 2 classes - Piate: Plate 50K
1148 2 classes - Pat: Plate_6 0K
1148 2 classes - Piat: Plate 70K
oSz o)
11482 classes - Piat: Plate 9 OK
— )
Custer Cassfy 2Nk





image72.png
s 020 0 ==
@aapga [Comectly Classified Instances 30 9375 %
(Incomectly Classfied Instances 2 625 %
[Kappa satsic o
[Mean shsote eror 00625
[Root mean squared eror 025
[Reative absclte eror 125 %
|Root relative squared 0 %
- (Coverage o cases (095 leve) 9375 %
Descriptor_0| rel_region size (095level) 50 %
Total Numberof ]

<=10.618125

>10.618125

[Class1 (16.0)

0161 b =Class1





image73.png
£ HCS analyzer v103

File

Edt Plate 0

Dimensionaity Reduction

-+ Plate  Screen

Systematc Eror dentiication & Corection

Plug-ins  Help

Nomalzation

Classfication & Clstering

115631

(e

Giobal only
Selected

7] Applyto ol pltes:

Postive (0)

Curent Desorptor

Descrptor_0

Descrptor List
[9] Descrptor 0
[9] Descriptor_1
9] Descrptor 2
[9] Descrptor_3





image74.png
Scatter Point / 3840 poir

Export  Copy to Clipboard.

Descrptor_0 -

Descriptor 0

116.378720899276

90.7049388502277

65.0312568011797

39.3575247521317

13.6837927030837

-11.9899393459643-
13.9803431322331 39.1857272102998 64.3911112883657 39.5964953664335 114 8018784445

Descriptor_1





image75.png
T ==
Plte Dimensions
Coumns 26
Rows. s
Data Name e Readout 0 Readout 1 Readot2 =
= Patorame || SRPO00SS  [SRPo00a7s | SRPOO0SI2
Vieh 386w Wellpostion || 02¢ 3 an
cat Descrptor |+ Druggable: Duggable Duggable
(Catalog Number Descrptor_[~]1 2
(Gene Symbol Descrptor [~ ] 1 2
Desciption [Desciptor [+ adrenocortical dy... | deleted n esoph..
7 |toasiD loosD___ v 65057 115123
Fuol Descrptor |+ | 08228554 07233504
size Descrptor |+ | 05823682 087035
Volume Descrptor_|-[5926911984 | 1833027118
Ratio! Descrpior__|-| 1442516279 | 2340326818
Fuo2 [Descrptor || 90.0408859 1765919403
i e P T -





image76.png
s ==

204

08

06

04+

024

Fluo

LocusID 3206

Name  4-aminobutyrate aminotransferase

Update and close





image77.png
Info

Histogram

Copy Visu.





image78.png
& GeneInfos

S

regulation in cancer - Homo sapiens (human)

[ Pathway menu | Organism menu | Pathway entry | Download KGML | User data mapping ]

Help

Homo sapiens (human) + [69) 100% v
TRANSCRIPTIONAL MISREGULATION IN CANCER Transcription factor fusion
.-
ot g
P
AL O LOSEIR | LMPO | | Diftrentition
(i) ™ el
oI e o
Ty
rSin3 Mutation
N-CoR. T1 1 A0 [GEFIR] —» DT
1821)(922,922) (TF)
i
EY —w- Differentiation
() PUL_|—+C—[Chily | —» Diffents
X e e posn
SATN221D) G Proliferat
- Cypting | — — ol
(TF) DA
| o CEBPE] o Diffsrentistion
[BA-1741] resistance.
111 DE2312) Dia _
FLZF H RARa -O—[ 1 " . Dilfentiation
(TF) N A - Iesistance,
R g |

Acute lymp hoblastic leukemia (ALL) (Precursor T ymp hob st keukemia)

_ - Diff
NPT pys  [MESL] [HORAS] —+ D
ML HENL —O— [iowan] [Horan] [SXL
H54Xa3532) Sixa | [Bva1 ] fooe
— HPGD | |GRIA3 | | FUTS
)
10,1 )(e24511), (7;10)(35,524)
T | o—»{cem ———»Difty
s oo e
1)(pL2p13), M1 L1311, KT G35pL3)
T [ DA Selfanny
HHEX | ———™fTel
T Lvin | " 4T el
B4 | MO—»{gm | —— —mDiften
oy e
Hodgkin ymphoma =
Amplifcation S T 1
el O [TRAFI - Polfen
(TF) D56 b
Hairy-cell eukemia -
Muton
Bl
)
Mutple myeloma
1416)(e32023) Dis  [COND2]——-#Myeloma prol
P = T o,
i) TTGE7]——— Meloma adh
HALApLE3D) o vano
1eH_Hoser > 5

]

ENTRY 3206 CDS_ Haapens z
NAME__FOXA10, HOXT, HOX1.8, HOXTH,
MGC12859, PL

IDEFINITION homeobox A10
IORTHOLOGY K03295 homeabax protein
HoxA/C/D10
PATHWAY  hsa5202 Transcriptional misreguiation
[CLASS  Human Diseases; Cancers; Transcrptonl
Imiseguiation in cancers [PATHsa05202]
POSITON 70152
MOTIF__ Pfam: Homeobax Homeabex_KN
PROSITE: HOMEOBOX_1
PROKAR_LIPOPROTEINGLY_RICHPRO_RICH |
HOMEQEDX 2
DBLINKS _TiCBIG: 182765442
NCBIGenelD: 3206
OMIM: 142957
HGNC. 5100
HPRD: 00845
Ensembl: ENSGO0000253293
UniPro: P31260
lassEa 410

MSARKGYLLPSPNYPTTHSCSESPAANSFLVDSLISS
|GRGEAGGGGGGAGGGGAGGYYAH

(GGVYLPPAADLPYGLQSCGLFPTLGGKRNEAASPGS
|GGGGGGLGPGAHGYGPSPIDLWLD

|APRSCRHEPPDGPPPPPGQQPPPPPGPPQPAPQATS
(CSFAGNIKEESSYCLYDSADKCPK

IVSATAAELAPFPRGPPPDGCALGTSSGVPVPGYFALS
|QAYGTAKGYGSGGGGAQALGAGP

FPAQPPGRGFDLPPALASGSADAARKERALDSPPPPT
LACGSGGGSQGDEEAHASSSAAE

ELSPAPSESSKASPEKDSLGNSKGENAANWLTAKSG
[RKKRCPYTKHQTLELEKEFLFNMY

LTRERRLEISRSVHLTDRQVKIWFGNRRMKLKKHMNR
ENRIRELTANFNFS
NTSEQ 1233

[sgtcagecagasagaoctatctactecsticgosasatiatcocacas
lcastgteatge

leagagageocogeogogaactetitiggtogaciogeicateagetc
laogcagagac

luagacagacggeagtgstagtageacagaggacageagogstaged

latctacgeocac -





image79.png
4-amincbutyrate aminotransf...[&]





image80.png
1 Transcriptional misregulation in cancer - Homo sapiens (human)

K[cc Transcriptional misregulation in cancer

Homo sapiens (human)

[ Pathway menu | Organism menu | Pathway entry | Download KGML | User data mapping ]

Homo sapiens (human)

- [

100% ~

TF: Transeripton factor

TRANSCRIPTIONAL MISREGULATION IN CANCER ‘Transcription factor fusion.
SParter 3-Parter
<Cancers of haematopaietic and lymphosl tiosuse>
Acute myeloid eukema (4ML)
Mutation
oy
AL O LOSEIR | LMPO | | Diftrentition
¢ [omcsr] (13 wsistarce
et syeloid lukercia Muson pys
[CEEPe s
™ 0y Diffntiton
Dk st
CEEral»0—»{ Fe2
e [ |/ diis | gy
N-CoR T1 1 A0 [GEFIR] —» DT
EN222) ) —
e — Sk Differentiation.
) FU1 |+ [CDifs | —» Diffets
D4
Diva
O Flizgita]— — — Prolifertion
SATN221D) G Proliferat
H | — . Prclifntio
ML HRARs S Epl] - — - Pglitaon,
(TF) DA
Jo—» CEBPe] . Differentstion
[BA-1iA1 resistance
L1212 D _
PLZF HRbRa O—>lety] | Difhentaton
(TF) N4 — ® resistance,
R s |

Acrwte o hoh b i bkem (411 (Precrsenr R homn hob st nemind

Acute lymp hoblastic leukemia (ALL) (Precursor T ymp hob st keukemia)

(L19)22p133) oy [MESL] [Hozag — DY
L H ENL O [aogai [Foxa [SI1
AN Sixa | [Bva1 ] fooe
— HPGD | |GRIA3 | | FUTS
(TF)
H10;14)(e24,911), 47;10)(g350424)
Tx1 ——w| o—»{corr __wDi
(TF) DN& es|
el(11)(p12p13), {111 4)(p1 31 1), AT;11)GESpL3)
TMOZ (TF) oA sel
HHEX] ———"5f"
1DBL Lyit |7 i
B7 | ™O—w[pm | ———»Di
Dita £
Hodgkin ymphoma _
bnpiifeaton oy EEIAD [TEFT] )
ol |———— O—»[TRapt] [Baxr] 1»Pr
) gt
¢ co6 ] [cpa] |
Hairycellieukenia .
Muton
Bl
(TF)
Mutple myeloma
asle2azy Diys [CONDZ]—— > Myelors
P = T o,
] TGE7]———*Myelons
H414)(p16532) ‘boe
T T S T
1
b4
Lymp hophsmacytic lymp homa O——w-[CCND2}-— —* Celleysl

9:14)p13532)

Diia





image81.png
£ HCS analyzer v103

[
File Edi SRPO0ISD - Plste | Screen | View Plug-ins Help
Visuslzation v |
=+l Dimensinaity Recuction | |1, | Systemati Eror dentficaon | Quality Controlz  » lien Gissfcation & Cterng Repot Eot

Postive (0)

Gene Analysis > Find Gene ~ Ctrl+Shift+F

1 Curent Desciptor

Pathways analysis

[ ]
VETE

7] Rato
7] Fluo2

fobal only
Selected

7] Applyto ol pltes:

Display lass

Toz=zZrAS-TOTNMOO® >

[ [l 1 [ | [ | ] |
N (] (N O N ) O ) ([ I 1=





image1.emf
Plate384 Well 384wCat Catalog NumberGene Symbol Description Locus ID Fluo1 Size Volume Ratio1 Fluo2 Texture Rand1 Rand2 Rand3 Rand4

SRP000459D24 Druggable 1 1adrenocortical dysplasia homolog (mouse) 65057 0.822859 0.982368 59.26912 144.2518 90.04089 104.5234 48.66298 35.7505 36.28192 14.83044

SRP000479P20 Druggable 2 2deleted in esophageal cancer 1 115123 0.72335 0.987039 183.9027 234.0327 176.5919 231.5573 0.90994 7.755161 22.86228 23.36147

SRP000502G11 Druggable 3 3hypothetical protein CG003 57574 0.909086 0.724062 137.0043 139.0109 74.81597 195.0901 34.82006 5.351135 40.45101 0.397935

SRP000469P09 Druggable 4 4hypothetical protein 15E1.2 54708 0.75825 0.943229 58.89768 196.4233 54.3536 118.3427 35.54298 47.71962 46.30442 9.891081

SRP000463F05 Druggable 5 582-kD FMRP Interacting Protein 10299 0.913974 0.936443 144.9422 481.5817 40.2687 156.4878 33.01084 18.35786 16.16318 32.8679

SRP000474K16 Druggable 6 6hypothetical protein 384D8_6 64844 0.951024 0.940594 22.85816 499.7528 7.579783 113.2114 3.485309 5.603355 46.58561 42.21598

SRP000480D10 Druggable 7 73' exoribonuclease 92979 0.983895 0.993165 23.72045 125.6528 19.88528 38.27095 17.06228 42.23741 13.09605 14.63739

SRP000466E13 Druggable 8 8gamma tubulin ring complex protein (76p gene) 23591 0.781394 0.883409 288.7793 1185.202 112.0497 310.5889 35.11503 24.39241 49.79913 9.485995

SRP000439D16 Druggable 9 9putative binding protein 7a5 1731 0.941405 0.86835 180.8949 209.4964 103.6978 140.4776 10.84225 7.070599 28.18577 36.48984

SRP000469M24 Druggable 10 10hypothetical protein FLJ13511 54464 0.912182 0.935283 146.6728 523.9838 132.9783 224.7909 6.941006 2.267799 18.93494 38.59139

SRP000439D18 Druggable 11 118D6 antigen 55964 0.916994 0.882256 155.6142 187.1925 54.14138 91.08958 38.03543 4.182601 11.05194 11.11748

SRP000439D20 Druggable 12 12alpha-1-B glycoprotein 23157 0.917484 0.791711 154.0979 120.4616 122.1243 100.1224 13.09587 14.02423 6.747342 1.986987

SRP000465I08 Druggable 13 13ataxin 2-binding protein 1 23176 0.937335 0.848266 113.7 171.2941 25.2004 33.61339 3.128092 1.025906 6.887327 31.69431

SRP000484I21 Druggable 14 14ataxin 2-like 151011 0.861691 0.974512 61.80003 157.4689 96.43404 89.46256 47.26814 33.45952 5.308625 29.8281

SRP000438A05 Druggable 15 15alpha-2-macroglobulin 55752 0.347707 0.899089 67.99509 159.2583 90.66948 154.9841 25.47527 14.39126 1.822695 33.67102

SRP000483M07 Druggable 16 16alpha 1,4-galactosyltransferase 143501 0.727905 0.732156 173.724 630.3225 146.8105 148.0179 44.21375 14.64555 22.50402 47.52822
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